Unable to Play Gears 2 on Xbox One

Whenever I try to load up Gears 2 it either :

  • Doesnt load up at all

  • Game crashes and makes this weird noise.

  • I get to the menu but if i try to do to campaign or anything else it freezes.

Have it via game pass. Uninstalled and reinstalled it. Didn’t work.

Want to play it but can’t whats the point of TC having this game available on gamepass if its unplayable.

Has anyone else got it via gamepass and unable to play it :roll_eyes:

Or does anyone know how to fix?

2 Likes

I was unable to play it as well, but I never quite figured out what was going on with it.

Maybe @TC_Kilo1062 could provide some help?

I’m having this same issue too.

Ran into the same thing. I got stuck on an infinite loading screen.

Dont know whether its the same with a disc version or if its only the gamepass one that is not working.

I have a digital version of Gears of War 2 (not from gamepass).

It worked fine for me.

For giggles sign in using a different account and see if it works.

2 Likes

Tried it for funzies lol infinite loading screen / frozen loading screen

1 Like

The fatal bug you are referring to doesn’t have a fix. It’s usually account specific though.

Once an account became corrupted it was near impossible to fix.

There was a way of logging in to a working account, starting a game, then logging quickly into the corrupt account. Never worked for my son.

1 Like

How do we get the bug on our accounts? And there is so fix for it what so ever?

Usually playing splitscreen, the profile itself corrupts. This bug was introduced in TU6 (last major update Epic made for Gears 2).

There is actually a fix, but its to deliberately trigger the profile reset glitch, wiping all your progress, you can make this more likely to happen by signing in and out before the freeze part, this worked for me many years ago when I had the same issue and took me maybe half an hour of trying.

Its a horrible bug and a horrible solution, but that is the only advice I can give.

1 Like

Well you can try to start the game offline then you’ll have to start the game on training grounds with a secondary account then sign out and sign in with your main gamertag while game is loading

1 Like

It worked for me after trying to do just that. It won’t work if your online. So go to your network settings and play offline then try to sign in with a secondary account with training grounds. As soon as you see the loading screen sign out and sign in with your main gamertag account

2 Likes

Gears of war 2 hanging after first screen:

Thanks for the above advice, I was able to clear the faulty profile, main thing is to be offline when you launch gears2,but first clear local saved 360 games ( from storage tab). While no gamer tag logged in Go into training and then log in, also play campaign some to get new save, exit game, then go online and log in GT. I actually dug out my 360 to clear the profile as it gives more time to log in during load of the training/ submission step. No “dummy” gamer tag required, run with no GT logged in to get game to work past first “red skull” screen. The new 360 based Gears2 profile works correctly on the Series X, cloud saves updated /downloaded at launch of game on the Series X and work. It does clear previous progress though but at least you can play

2 Likes

Issue present on both digital on series x and on 360 with disc, related to corrupt profile/ saves not game itself, so reset for uninstall does not fix. See below for cloud saves reset steps

Thanks for the background info, I agree on the split screen play being the culprit as I played previously with no problem, issues started after split screen play on new series x. Only online co-op going forward:-)

1 Like

I had a bug where the game would crash as soon as it tried to load the profile settings/cache, if I remember right I ended up deleting the cache for the game (the 360 cache and Xbone cache) and just starting anew.

Not the best solution but it’s the way I remember fixing it. Because it was a data issue (Game only crashed when you hit START at the beginning, but would load up the first menu with no issue).