Stuttering without FPS drop

Hi all.
Played the game just fine since release until mod October. No crashes, FPS issues, none of that.
Tried the game after Op 2 release and now I get weird fps drops/stutters without actual FPS drops or stutters showing in MSI Afterburner (frametime and framerate graphs are rock-solid). It plays ok for 20 or so seconds then it seems that FPS has dropped to 30ish for a couple of seconds and then back to normal. All the time. The main menu also struggles with it.
My specs are:
RX 5700
Ryzen 1600 3.6 GHz
16 RAM 2400 MHz
HDD 3TB (checked for bad sectors - almost as new)
Win 10 1809

Again, I didn’t have any issues with the game prior to it, The only difference was that I had Win 1903 before.
I tried new and old AMD drivers (19.12.1 and 19.12.2) - same. Vsync on and off, Enhanced Vsync on and off. I tried to lock fps with RivaTuner. Windowed and Borderless - same deal. Other games are not affected.

Fixed this issue by turning off Async Compute.
Strange, considering it worked perfectly fine before.