Studios Horde Challenge Not Registering

Is this challenge not registering progress for anyone else?

It’s not registering any progress on the Rewards webpage or the actual achievement.

There is a note about it on the Rewards web page but that says for PC users and I’m on Xbox… still not registering.

Make sure you’re not doing private matches by yourself. They don’t count (TC failed to mention that).

If you’re doing private games, you need at least one other player with you for it to count.

Hope this helps

1 Like

The rewards page doesnt work for anyone. Its mentioned as a PC issue as we dont have a tracker like you do on Xbox.

Its concerning that the ingame tracker on xbox itsnt working for you. As the poster above said, solo doesnt count. Are you playing with other people?

Yes, have been doing all public, normal Horde matches. Can’t figure out what I could possibly be doing wrong?

Webpage tracker didn’t register for me, my achievement tracker DID work however, when I completed it the webpage said 0/200 with a button that said Claim your prize and it worked.