(Solved... Maybe) Gears 5 not loading out of no where.( Microsoft store dependency installer. App cant open. Reinstall gears)

Is anyone else having an issue loading gears on PC?
I haven’t been on in like 3 days and yesterday i went to load up but i was greeted with a crash. I figured no biggie and went to load up again. This time I was greeted with windows asking me if its ok for a program called “Microsoft store dependency installer” to make changes to my computer.

I thought it was weird but i pressed yes. After that I get another pop up saying:

“this app can’t open
Check the windows store for more information about gears 5”

So i go to the store and the Microsoft store says:
“this app has encountered a problem. please reinstall it to repair”

At this point I’m annoyed because i just wanted to run some gears before bed and 70 GB isn’t huge but its not small either. I figured my internet it would take some time to download so i just decided to set it to download and i went to sleep.

This morning i wake up to try it out and I’m getting the same messages. Do anyone else have this problem?
Anyone know what its happening or have a fix?


Ok so not just me that had this.

So i have a hunch whats going on,
With the new store coming in operation 4 and the changes that are being made, there was a needed framework update to how gears 5 and the microsoft store interact, however it seems that on certain driver versions there appears to be some sort of issue,

Yesterday i changed my drivers (Nvidia) because of a seperate gears 5 issue, when i launched gears 5 i was met with the same request you had, and same thing happend crash, had to reinstall to fix, tryed that and it failed, so i rolled back my drivers to the one i had, did a complete uninstall and reinstall was met with the request, clicked yes and the game launched with no problem, been stable so far since then.

Interesting. The only change I made was adding extra usb slots in the back so I also made a chage to my system but it wasn’t anything with video drivers. I’ll try to un plug it and do an uninstall/ reinstall and see what happens.

Did you found a solution?
I’m having the same issue of the popup dependency installer.
Reinstalled the game, and the issue continues. :frowning_face:

My little brother, my best friend and myself are all having this issue.

First one to have this issue was my buddy, he just bought a new gaming PC to play Gears 5 and when we had everything all set up he went to play, it booted and went through the intro video, then crashed once it was loading the main menu.

My little brother also had this crop up on him when he did a clean install of Windows 10, no problems before hand, but once he reinstalled Windows 10 it wouldn’t let him play.

Now, after playing for months with no issues, this morning I went to boot the game up to do some last minute medal collecting and now I am having this issue. It is really frustrating, none of us were able to figure out any kind of solution, and the only workaround we found was buying Gears 5 on Steam, which we shouldn’t of had to do to play this game. Really hope people who don’t have the means to buy it on Steam are able to get a fix soon, especially with Operation 4 being hours away.


So ill be honest I’m not sure if this will work for everyone considering @x00FireWolf00x had to roll back his drivers for it to work, but after he mentioned his drivers i checked mine and realized my drivers were from 2 months ago. I’m not sure how because i got my new GPU 2-3 weeks ago and i assumed the latest drivers would install but maybe that was a mistake on my part. Anyway, I installed the latest drivers (AMD) which had released about 5 days ago and I haven’t had a problem with it yet, I tested it this morning and it loaded up. The only thing worried about is that it says i have to update the game because op4 is coming. once i do that ill let you guys know if it still works.

EDIT: Yeah so exactly what i was afraid would happen, happened. I updated gears for op4 and was greeted with the same issues. sorry guys. no fix yet.

Try again please- an update rolled out.

If you are still experiencing the issue, please send a ticket into Support with the details you remember (where you were in the game prior to this happening, etc.)

I just had another friend go to play it today and he just encountered this issue after months of it running just fine. I wouldn’t think the issue would be drivers as we were playing just fine the last couple days and there hasn’t been any driver updates that we installed on our side. He had the exact same thing happen, booted the game up, went through the loading title videos, then it crashed to desktop. When he tried to boot it back up it gave him the messages noted in the photos in the OP’s post. Not sure what is happening but needs a fix for sure.

1 Like

This is also happening to me. Haven’t playing Gears 5 in about 3 weeks, but came back for Operation 4 and now this. I’ve tried every suggested solution, but nothing works. Incredibly frustrating.

[quote=“x00FireWolf00x, post:2, topic:47313, full:true”]
Ok so not just me that had this.

So i have a hunch whats going on,
With the new store coming in operation 4 and the changes that are being made, there was a needed framework update to how gears 5 and the microsoft store interact, however it seems that on certain driver versions there appears to be some sort of issue.[/quote]

I really, REALLY hope that it’s not driver related…Afterall, I barely gave this game and TC a chance after they completely broke Gears of War 4 on PC for Nvidia users after a year with some bull**** excuse about Nvidia changing their code that made it too difficult for TC to fix, rendering the game literally unplayable for many people (translation: “we either don’t care or are too stupid to do what other developers have done to fix the issue.”). I swear that if this another end-of-the-road issue like that, I will be done with TC and Gears indefinitely. Period.

1 Like

same here op3 was working fine then op4 came out today now my pc isn’t playing the game when it
reaches the loading screen for the main menu my pc crashes sends me back to my desktop home screen
any suggestion let me know please.

1 Like

I am back again with ANOTHER person I know receiving this error. So out of everyone I play Gears 5 with, there are now 5 (including me) people who have this issue. There has got to be others having this issue, the chances of so many people I play with experiencing this same problem is ludicrous. Any help would be seriously appreciated, TC.

1 Like

I have the same issue been playing the game since launch and now I have the same issue as in the screenshots.

If you havent already, everyone with this issue send in a support ticket with as much info on the issue as possible, (what you where doing before this happend, your PC specs, driver version, if your use steam or windows 10, etc.) that should help TC narrow down the issue faster.

1 Like

Same situation here. After OP4 game will crash after intro videos. Uninstalling the game, troubleshooting Microsoft Store didn´t help.

Be sure to send a ticket https://support.gearsofwar.com/hc/en-us/requests/new?ticket_form_id=360000507032

Same here, but I installed the game again and everything was fine. But I’m constantly kicked out of matches with kinnerlake, eestana. My internet is great, my pc is up to date.

Yeah…I’m done with this game and TC. They rendered Gears 4 on PC unplayable, couldn’t fix it, and now have done the same with Gears 5. Peace out. Not buying any of your games ever again. Good luck.

Still no fix for this? I’ve tried so many different “fixes” for this issue and nothing seems to work. I find it hilarious that when a good update finally happens, I can’t even play.

I have the same problem. Microsoft store is a joke.

The only “fix” at the moment seems to be purchasing Gears 5 on Steam instead of using the Windows Store. My buddies and I bought the game on Steam after we had this issue and we have been playing without flaws since then. We shouldn’t of had to buy the game twice but if you or anyone else want to play it badly enough, this seems to be the only option for now.