PC Users be warned... the Nvidia Patch didn't fix anything, but I may have stumbled on a work around

[Octus Edit: Entirely inappropriate behavior and inaccurate claims with regard to the cause. We understand the frustration but keep it clean and constructive. This thread is only remaining open because the rest of your work / investigation is actually clean / constructive.]

video to follow.

Edit: (about an hour later)

Huh… interesting.

I just tried four times to replicate the crash issue.
Two times it crashed as expected in the cut scenes.
Two times it worked and loaded the next scene with no problems, oddly enough it was when I was recording it for youtube and to show you guys the problem.
I will be uploading the video and providing the link… but that’s a very odd work around.
So basically if anyone here has the crashing issues in campaign (as in it freezes during a cut scene and won’t continue) try loading up your Geforce Experience overlay and try it then.

Will report back soon.
Until then, here is the video.

Edit: I can confirm that it (for me anyway) doesn’t crash if you have your Nvidia overlay running even if your not recording. I just played through 2 levels, it loaded the rendered cut scenes, then into the new area no problems…

Folks who are having crash issues, try that. Just turn on your Nvidia overlay (GeForce Experience) and give it a shot.

1 Like

Just to confirm… When you say crash, you mean the game just freezes and you can kill it by alt+f4 or alt+tab and kill it by the “x” button on the window, right?

It used to freeze up my entire PC, so it’s a bit better at least.

So I guess it’s true that it doesn’t BSOD anymore. But it’ll still freeze up the game.

I haven’t tried the workaround yet. My second freeze happened after like 9 hours, so I’ve rebooted an am going to see if it happens again.

I didn’t install GeForce experience with the driver this time. But might give it a go.

Mine had a BSOD.

1 Like

Oh really? Ugggh.

Sadly yes. After about 2 hours today.

I think we’re going to have to take to Nvidia’s forums too to spread awareness that it isn’t fixed.

I really don’t think that TC nor Nvidia are going to try again though. That’s probably the last we’ll hear about it.

I’ve kind of lost the will to fight this fight anymore though, all that frustration and typing for nothing basically.

I have little faith that any further effort on my part will result in any progress on this matter

1 Like

I’m not surprised at all…feel bad for the PC players

So many icons on your taskbar :fearful:

Yeah but its a clean desktop lol.

I agree :+1:

I’m super OCD.

I have one pin on my taskbar and one icon on my desktop.

Followed by 8 tiles in a 2x2 layout on the start menu :laughing::v:

1 Like

As in suprisingly only during campaign it would freeze during the rendered (not done in engine) cut scenes. Alt F4, hitting X, and sometimes ALT TAB wouldn’t work. Sometimes when it happened it would mostly freeze up windows and on one or two occaisions would require a reset (holding down the power button on the case, obviously I’d rather shut down safely).

Unfortunately from what I’ve read in a couple of forums in the hours since it hasn’t solved it for everybody which is sadly a shame, and now I feel like the boy who cried wolf accidentally…opps
Doesn’t mean it won’t work for you hopefully. Its apparently worked for some folks.
As I said I just accidentally stumbled on this and at least for me, so far so good.

I can tell you, at least from the TC side, we’re actively looking into all these reports as we speak and monitoring crash rates.

It’s too early to say what the next steps are, but emails between QA, Engineering and Community have been flying around constantly since initial reports came through to look into this further. Our desire is to get this rectified.

5 Likes

Hypothetically if Gears 4 on PC never gets fixed, is Gears 5 likely to have the same issues?

my guess yes

I still have the splash screen crash, bought the game in december 21, and I really want to play for the first time.

I think this is related with microsoft store or something, Because I only see the Gears4 logo and it closes up.

Did you follow our Known Workaround on this issue? Check them here.

Well, that’s encouraging to hear. My skepticism was due to the amount of time it took us to get to this point.

I’ll be delighted to have you eat my words. So I’ll eagerly await the next title update :slight_smile:

Thank you for chiming in, I love the enthusiasm and the desire to see this through :+1:

Yes, I actually check once at week to see if there is any other solution to try to fix it.
I have done:

  • Wsreset
  • Full clear uninstall/install of the game
  • Reinstall the game without delete it (using two local accounts)
  • PushtoInstall service set to auto
  • Open it from the MS/Xbox application
  • PC Up to date
  • Latest Nvidia Drivers
  • Select the GPU to run the game from the Nvidia Panel
    And there was a Powershell script to download in one of the forums, but I don’t want to risk my system with things like that.
1 Like

Hello mate,

I had the same problem before, and the the resolution was simpler than that,
I’ve only downloaded a random app from windows store, e.g. whatsapp, then reopened the game smoothly.

Cheers,

This new patch has been working perfectly for me anyway, Am I the only one? x)

1 Like