None of the game modes finish downloading (PC)


I’ve downloaded Gears 5 twice already on PC, over 65GB download.
Still, the main menu always shows all games modes are still downloading.
The only thing available to play is “BOOT CAMP”.

Whenever I click on any of the other game modes, I get an error: “This mode is still downloading.”

There’s no progress indicator, so I don’t know if it’s actually downloading anything.
I checked Task Manager and looked a network usage and it doesn’t seem like anything is downloading.

This is very frustrating. Was really looking forward to playing the campaign, but can’t even get it to download.
Any idea on how to fix this?

Here’s a screenshot of the main menu:

Someone reported a problem with infinite download regarding HD textures, as soon as he uninstalled them the game played fine.

it’s not the HD packs…it’s all the game modes. The only mode i could play is the training mode. I tried to install the game 5 times already and still not able to play. It’s been 2 days since the early access and I feel we are more like early beta testers but we r paying $2 for it.

1 Like

Mine was unplayable - story on pc. I downloaded it again and updated my drivers. That worked for me.

All my drivers are up to date. I’ve already delete the game and redownloaded, but still have the same problem. It just stays there, infinite download.