Jack glitch in act 3

Played some gears co-op with my friends yesterday and did all of the side missions in act 2. Got a bunch of upgrades and even found some ultimate abilities for jack. We went to resume our co-op game and this is what I got for jack. This was a massive grind yesterday and now it was for nothing. I have no motivation continue this game or to do any of this again.

4 Likes

I also had this issue yesterday and logged a bug report.

1 Like

Happen to my sister shes playing jack can’t upgrade but if I switch to jack I can upgrade

2 Likes

Same here, yesterday me and my partner played as JD and Del and worked FINE. Now, just 40min ago we tried to start the Chapter 2 as Keit and Jack and then this glitch happened.

The worst part is: when this screen shows, I can’t even exit

1 Like

I have also had this bug and reported it to TC

Same here


Happened during coop when we found the stim upgrade

It happened to me after we finished act 2. To make matters worse, collectibles are still not properly saving. We collected something like 20 collectibles in act 3 and the whole time it said 0/24 collectibles. At one point it said 3 and when down to 2. Also what’s the deal with checkpoints. Why don’t checkpoints save progress mid Chapter, do I really need to finish a chapter in order for everything to save? What if I have to leave mid chapter?

Same here. My friend started as jack. Played fine. Act II i played jack. All good. Next day while finishing act II he played jack. Perks that we found/upgraded weren’t working. He had the same screen as shown by others. We quit, i took over jack, everything worked for me. Now he can never be jack for the rest of the campaign?? We hate it. I also saw a thread where people complained about jack not being a third player. I think jack is awesome when upgraded. I clear a lot of forward enemies for the team.

I had a fully upgraded zapper, I had the ultimate ability for the flash, stim, and shock trap. I was taking out scions and pouncers by myself on experienced difficulty, now my friend who didn’t play a second of jack has to play jack and he doesn’t know jack ■■■■ what to do with him. Collectibles still aren’t saving either. It’s so frustrating.

Had this glitch happen TWICE once on Intermediate playthrough then AGAIN on a beginner playthrough trying to rectify it. It has put me off doing any more campaign. I really can’t be ■■■■■ to run through the campaign first 3 levels AGAIN for a 3rd time.

Happened for me too at the Stim pick up, then again when we have to stim to get through some gas.

1 Like

How do you report it to TC ?

I usually fill out a bug report form with screenshots or videos and as much detail as I can, I have also spammed Octus with a list of bugs.

https://support.gearsofwar.com/hc/en-us/requests/new is the place to report them

My abilities for jack frequently would not show, but seemed to still work as intended when selected. Most of the time the images loaded after a minute or so.

Same issue on the same spot, is there a work around at all besides starting the campaign over again for the 4th time?

We are in act 2 with same issue. Anyone get a fix?

These are just vanished. Looks like that but all the upgrades and everything are reset and nothing works.

1 Like

I realize that so far the only info we’ve been given is to submit a ticket but hoping someone found a fix that doesn’t make us wait forever or start over.

1 Like

Try having Jack be the host. So if you usually play as Jack you start/host the game. That’s been working for us, since switching to jack being host we haven’t had any issues.

1 Like

Thanks. We tried that and didn’t work for us. So we ended up restarting the beginning of the ice bit in act 2 and that fixed it for the host but the host only. The coop person still can’t change any of their jack stuff. But as long as someone can it works lol

Wow that’s weird that it let’s the host change Jack’s stuff. Normally no one can but the person playing as Jack.