Gears Forums

Is there an update coming to fix Gears Of War 2's Campaign?


(HUG3 N3WB) #1

Hey @the-coalition

I noticed today that I have updates pending for Gears 1, 3 and Judgment, but no update for Gears 2?

Gears 2 is currently unplayable if you’re signed into your Xbox live account (in-game) whilst playing on the Xbox one.

It locks up the entire game (freezes) either on the title screen or in the training section at the beginning of the game.

Apparently it is playable if no one signs in, but I don’t have the time to beat it in one sitting, and I’d also like the achievements (I’m beating the game again on my new account).

Is there any chance a patch could be released that addresses this issue? I know this is probably more of a Microsoft backwards compatibility issue, but I figure who better than TC to forward it on.

This is also a wide spread issue. A quick google will show you that this is affecting a ton of people.

My fiancee and I would love to beat 2, 3 & 4’s campaigns again before 5 comes out! We’ve already beaten Judgment and Gears 1 again, but were left extremely upset when we couldn’t play Gears 2 :frowning:

Currently our plans are scuppered :frowning:


(GhostofDelta2) #2

Hey mate, am I correct in presuming it only locks up when your account is signed in?

If so then its unfortunately a glitch that prevents your account from working with Gears 2. The only way to fix it is to do another glitch, which results in your data for Gears 2 being wiped.

Im hoping this is a different issue that can be fixed, but what I am describing above has been an issue since TU6.


(HUG3 N3WB) #3

It does indeed only lock up when accounts are signed in.
I heard about the data wiping suggestion and wiped the data associated with the game. It still froze though :frowning:

I have no data to care about at this stage (was just playing the part where you train the rook for fun) and got to the end of that and it froze.

If you and your divine wisdom know of a way, do tell oh wise wizard :smiley:


(Aziz XXCOOLXX) #4

I have seen TC Vectes in a post saying that they almost cant do fix anything in the legacy games, But I really hope they will fix the glitch somehow


(GhostofDelta2) #5

It needs specifically to be wiped using the glitch that caused people to lose rank and all progress in Gears 2 (and 3 and Judgment). You will keep your earned achievements but nothing else.

It occurs when people try to sign in and instead of loading up your profile properly, it loads up blank data, as if you had never touched the game before. When people played after this (if they didnt back out and load in properly) it would overwrite their proper data . This occurs every now and then,

When I had the frozen profile glitch I would load up the game and sign in and out while it was loading. After trying about ten times I got the blank profile glitch as mentioned above, lost my data but could play again.

I don’t know 100% if that is what you have, as that glitch would never let anyone past the title screen (unless the account wasn’t signed in, in which case it would work fine),


(HUG3 N3WB) #6

That’s exactly what happens yeah. The first freeze happened during the tutorial section, but after that I’ve never been able to go past the title screen.

I’ll give your advice a try. Thanks bud :+1:


(GhostofDelta2) #7

No worries. Hope you are able to recreate it :slight_smile:


(AcuteLime88) #8

Hi, i have the same problem now, any fix??
:):):):slight_smile:


(Acid xxx) #9

Just delete the checkpoint data save file. you’ll lose the campaign progress but nothing else. No need for any 2nd profile glitching here


(GhostofDelta2) #10

If its the glitch I am thinking of, sadly that won’t fix it. Worth a shot though.


(Acid xxx) #11

Its fixed it for me several times. Assuming its the glitch that freezes the game upon loading. Don’t know how many of these glitches there are xD

the problem can only be caused by corrupt data either in the checkpoint save file or the gpd file in the profile. deleting the checkpoint save will make the game create a new one upon loading, If this still doesn’t work then recovering the profile will fix a corrupt gpd file


(Slipping Flames) #12

How do you do that if it freezes immediately upon loading? Load with no profile first? Delete all game data and redownload?

I’d pay money to fix my sons account. I’ve tried the known potential solutions, but either my timing is off or it’s something else.