Gears Forums

Gears of War Ultimate Edition Windows 10 drop fps after v.1809 October update

Gears of War Ultimate Edition only has DX12, so there is nothing to force, as there is no alternative.

No idea how much effort it would take to fix it, but apperently they dont even have the spare manpower to at least identify what the problem is. If it takes to many manhours to solve before the release of GOW 5, so be it, but did they actually identify what the problem is and how much work has to be done to fix it? It would really suck if after the release of GOW 5 someone takes a look at GOW Ultimate Edition and identifies and fixes the problem in a day. (But what do I know, maybe someone already took a look and could not identify the problem after many hours and put it on the ‘to do after GOW 5’ list)

I posted this in another thread but I wanted to play the campaign at a higher framerate than XBOX but it’s just not possible. I am using maybe 35% of my CPU/GPU power according to my settings (2080ti and i7 8700K) and the FPS drops well below 30FPS.

It wasn’t like that at launch in regards to DX12, it changed with the same Windows update that made GoW4 temporarily unplayable as well.

That’s the issue . Please don’t come at me if you don’t know what you’re talking about. I’m tired of fake experts spouting nonsense.

You didn’t even have the balls to quote me, you peasant.

2 Likes

it would probably take a few more people than that, but yeah, this was my point. I find it highly unlikely that that’s the case. They just don’t care.

I’ve started a chat sequence with Microsoft for a refund. This is absolutely absurd.

I’d just like to point out that last night, I setup a dual boot on my PC with Windows 10 v1803.

Spec
i7 9700k @ 5.2ghz
32gb DDR4
RTX 2080Ti OC
3tb Evo M.2 NVME
120hz Predator 35" UltraWide Z35P (set to 120hz with GSync Enabled)

Playing the game at 3440×1440 with everything maxed (4k textures), the game starts off in the prison cells at a solid 120fps. After about 5 minutes, nearly through the first small chapter, the game dips to 45-50fps… then back up to 100fps… then back up to a solid 120fps.

Through out first two levels, it varied between 50fps and 120fps. I haven’t messed with the graphics settings yet to see if they make any difference… I would say that the dips seem random because at times, when it happens, there is NOTHING happening in FOV, No enemies around, I could literally be looking at the ground…

Can anyone confirm that they used to get a solid high fps without any dips at all? Is it just poorly optimised UE4?

Heres a reality check. Gears 4 sucks and Gears 5 is not even out yet. Maybe trying fixing which is actually good and out for a decade now instead of making poor excuses. As I said before in my comment, this thread is up for 5-6 months now. It seems to be in ur lowest of lowest importance.

What do you mean with not quoting you? I replied to you, right? Everyone can see to what comment I replied to.

I am also not ‘coming at you’ like its an attack or something, I didnt accuse you of anything or call you names or anything, I just pointed out that, while Metro Exodus has DX11 and DX12 and DX12 is apperently forced when you play that game in gamepass according to your post, Gears of War Ultimate Edition only has DX12: No DX11, no OpenGL, no Vulkan, or anything else, there is only one renderer. So if Windows would be forcing DX12 on games, that wouldnt change anything for Gears of War Ultimate Edition in that regard.

But maybe I am understanding you incorrectly (which can also be a possibility. No need to immediately call people ‘fake experts’ and take a somewhat hostile stance with the “You didn’t even have the balls to quote me, you peasant.” when there could just be a misunderstanding going on here): What do you mean with ‘forcing DX12’? I assumed you meant the renderer, which should not matter for Gears of War Ultimate Edition as the game has always been DX12 exclusively as said before. Do you mean a forced full screen in DX12? Forced borderless window in DX12? Or something else?

This is interesting, I thought 1803 was fine… I’ve clearly miss understood. I am currently installing v1709 to see how it plays.

How many people would it take? It’s clear that caused the issue (Windows Update). This isn’t rocket science.

It absolutely used to run flawlessly. Read the thread.

I have been messing with this for a good few hours now.

This is a PERSONAL opinion and NOT claiming it is perfect, there are serious issues with this game and I hope the devs come back to it.

My Spec:
i7 9700k @ 5.2ghz
32gb Corsair Vengance DDR4
3tb Evo 970 M.2 NVME
RTX 2080Ti (stock)

I disabled Virtualization. Not convinced this made much (if any) difference, but, why not.


Windows 10 with a higher build than 1709:
I get a stable 90fps, without dips or stutters.

In the nVidia Control Panel, I set my monitor refresh to 90hz, Gsync enabled, V-Sync Enabled.
In the game graphics settings, I set the following:

VSYNC: OFF
FRAME LIMIT: 90
ANTI-ALIASING: FXAA
TEXTURE QUALITY: 4K
ANISOTRPIC FILTERING: 16x
SHADOW QUALITY: LOW (this has a BIG impact)
AMBIENT OCCLUSION: ON
MOTION BLUR: OFF (personal preference)
VISUAL EFFECTS QUALITY: HIGH


Windows 10 with build 1709:
I get a stable 120fps, without dips or stutters.

In the nVidia Control Panel, I set my monitor refresh to 120hz, Gsync enabled, V-Sync Enabled.
In the game graphics settings, I set the following:

VSYNC: OFF
FRAME LIMIT: 120
ANTI-ALIASING: FXAA
TEXTURE QUALITY: 4K
ANISOTRPIC FILTERING: 16x
SHADOW QUALITY: HIGH
AMBIENT OCCLUSION: ON
MOTION BLUR: OFF (personal preference)
VISUAL EFFECTS QUALITY: HIGH


CONCLUSION:

On my PC, to play at 120fps with everything maxed, I need to run Win10 build 1709. Fact. Seeing as there are a handful of Windows Store games which are NOT supported in build 1709, the hassle of dual boot etc is not worth it for the 30fps.

Personally, I am going to make do with the latest Win 10 build, 1903, stick shadows on Low and lock everything down to 90hz / 90fps.

Has anyone tested this by just limiting FPS in game to 90? I don’t like messing with Nvidia control panel

If you’ve never changed anything in nVidia Control Panel, then you are missing out on a true “G-Sync” experience (if you have a G-Sync display).

It has been documented that G-Sync works best when enabled in nVidia Control Panel, with VSync set to “On” in the nVidia Control Panel and then VSync set to “Off” in game settings.

It’s well documented and explained here: https://www.blurbusters.com/gsync/gsync101-input-lag-tests-and-settings/14/

I will try leaving nVidia Control Panel set to defaults, with these graphics settings, see if I get a solid 90…

I’ve now tested without touching the nVidia Control Panel.

Played the first level through with a pretty solid 93fps. Dropped to 86 fps very briefly during one of the explosion sequences but it didn’t interfere with game play at all.

Fascinating.

I’m going to reinstall and test now.

Cool. I’m not downgrading my Windows build for one game.

As for what’s happening, your 2080ti is essentially muscling out the shadows and post FX, where the busted pipeline will make the game run at around 40-45 FPS regardless of shadow levels on 10 series cards and other midrange hardware.

Yeah, I expect that’s the case. I have a 1080 in a laptop, might give that a go sometime.

I didn’t downgrade Windows build either, especially as it’s such an old build and lot of games not supported in that one. All I did was spin up an old hard drive on USB and boot to that instead, then unplugged and came back to normal (most recent) build.

Definitely a post build 1709 issue.

Thank you for the hard work and troubleshooting.

Its a long shot, but I have not tested it. I wonder if setting GPU to “Maximum Performance” power mode will help with performance? Seems like this is an application issue so clock speed may not solve utilization, but i wonder if it will help with frame dips or slightly higher FPS.

I run mine on maximum performance and it doesnt help unfortunately. On a 2080.

I will try moving shadows to low and see what I get

Somewhere between 30-70 FPS on a 2080.

Somewhat counter intuitively I am trying to remove a CPU bottleneck (I don’t believe there is one, 6700k @ 4.5).

I normally run at 1440p, but am running at 4k. Aside from Shadows on low everything is maxed out.

I have also forcing maximum power /w Nvidia control panel (unclear if it made an impact).

The drops are still pretty jarring (frame times).


Was poking around the INI files for UE3 optimizations (GoW;UE is DX12 bolted on UE3) but had no luck and screwed up my Windows store trying edit .ini files.