Gears of War 2 .. 2021 .. bugged with M/S cloud sync

Hello all,
Just wondering if anyone has tried to play GOW 2 on their Series X/S, XBONE S/X?
I played on the original Xbox 360, played through to the end, had a number of cloud saves, and a ton of achievements.
At one point in time, it synced with the Xbox Cloud Save game services.
Fast forward… many years to now… downloaded the game again, now playing it now on an Xbox One X.
Process goes as follows:
Xbox emulator starts
MS and XBOX logos play
Front screen comes up
Download/sync start then… freezes/locks

So I try another way, clear out the caches, delete the cloud saves (as much as I could), reinstall the game.
Same thing happens. Seems to hate the cloud sync.
I tried playing it offline on the Xbox 360 (after a fair bit of dusting mind you).
It worked, no problem. Started the game using my old profile, not linked to the cloud, using the disc and I could play the game, do a save, reload, no problems.
So I tried to link my Xbox profile in to it.
UH OH. Same issue, instant freeze and the xbox locked every time.
I even tried logging in the xbox 360 menu/system, accessing the saves and deleting it all, which worked to remove everything.
Then I logged back in to xbox services whilst in the game, froze again.
Has anyone had the same problem with xbox cloud save games or similar freezing their machines?
I’d like to do GOW 2 again linked to my primary xbox account for all the achievements.
Any help would be appreciated.