Gears 5 campaing doesn't install on Xsx

I’ve been trying to download and play Gears 5 on my Xbox and after the initial 45GB download nothing else is downloaded, I’ve tried deleting and downloading again at least 3 times.

There used to be a download percent at the top of the main menu but that was stuck at 100% and the progress bars were filled with the minimum amount, that is Act I for campaign and the basic MP, I left it overnight and it didn’t move, proceed to delete and redownload and that progress no longer shows up

This is downloaded from game pass
I searched for installation issues and many old post refer to an installation manager that seems to be removed.
One other thing is that I own and played it on steam, and the save did not transfer, but the collectibles did, not sure if it’s relevant

Any ideas on how to solve this?

image

edit: Yep, issue seems to be triggered by less than good internet connection, switched to a wifi from a different ISP and campaign installation started up, thank you for your help

tl;dr: Option showed up, tried to take screenshot, screenshot failed, rebooted the console, option gone

I think it is an issue with my internet connection or something else because I was about to reply to you that the option finally showed up but when I tried to take the screenshot my controller stopped responding and had to reboot the console. Now the option is gone