Gears 5 Act 3 Some Assembly Required Soft Lock W/ Video Proof

So me and my friend played all the way to act 3 on insane Some Assembly Required. we completed the cosmodrone but we died as soon as we got out and lost the collectibles but still spawned outside the building after completing it. so we went back in to get them opened the door and got in but jack won’t respond to any commands he won’t go through the vent to open the door. it saved when we got inside we have been stuck here a week. we are not going to play back through we have all collectibles and the last relic weapons on us. The Coalition has only been talking about achievements and progress trying to fix those not 1 word on the campaign killing glitch. if you have the same glitch or not check the video below to see what i’m talking about i have no idea how this got by testing coalition please fix this so some of us can finish the game.

1 Like

Bumping for the fix thanks in adv devs

2 Likes

This is STILL broken. I even tried resetting the chapter and it STILL doesn’t work.