'Game needs an update' loop (Xbox app on W10)

I’ve been 3 days trying to fix this error…when I launch the game through the Xbox app on W10, I get this screen like something has to be downloaded:

But I have nothing to download and I can’t start the game.

Things I tried:
-Check for game updates on both Xbox and Microsoft Store apps
-Check for Windows updates
-Reinstall the full game
-Try it on another PC (on both my desktop and laptop have the same issue!!)
-Execute wsreset
-Reinstall Xbox app
-Full restore W10

Any of those worked…the only way I have to start the game is to ‘repair’ it through the Xbox app settings, and it runs with no problem, BUT that repair reduces the game as a base (only available Act1 of Campaign and basic matchmaking), so when I want to play Horde, Escape, Hivebusters or Campaign after Act1, I have to redownload everything through the game menu…and if I close the game and try to execute it again I have the loop again.

What’s happening?? I assume this issue is on the server side if with a fresh restored W10 still happens…

uh oh, be careful showing Spanish on the forums

1 Like

I don’t know why should be careful of that…

inside joke

1 Like

PC Gaming lol, do PC gamers even have the fornicator?

I’m pretty sure their version of Horde has the same features as the one we console plebs have.

Is it neccesary to troll on a post where an user has an issue?..incredible.