Game freezing, or stuck on loading screen?

To the people that may have these issues, you can try this:

For Xbox One S or X -

  1. Power system off
  2. Unplug power cord from back of your Xbox One
  3. Unplug power cord from wall outlet
  4. Let system rest for 1 min+
  5. Plug the power cord back in
  6. Wait another minute+
  7. Power system back on

This should clear out system caches that could cause errors, and slowness of your system.

If additionally information is needed, you can go here: https://youtu.be/OY0b2-S1CsE

1 Like

Yup.

2 Likes

I tried to look through search to see if this topic was made before, but, I guess, I needed to type in more words.

I wrote this because I had to clear caches off of somebody system, and it worked for them. They couldn’t get pass loading screen for a couple days.

Good that this was brought up a while ago.

1 Like

Yeah I was just providing backup for your post. The method works.

1 Like

Mine can’t do the load after the start up logos. Also no keys respond to skip the logos, and then I have to press alt+F4 in order to try loading the game again through Steam.

I let it sit for 30 minutes once and it still doesn’t load after the first 3 logos show.

I regulalrly get the game stuck on the loading screen when i leave/finish an escape map (one below). Sometimes it can take 2-3+ minutes to load the results screen. Other times I’ve left it for 10 minutes before having to force quit the game. The cog symbol is still spinning so it’s not a full hang. It’s worse since mid operation 4.

The game has been re-installed and it made no difference. Operation 5 updates have also not fixed it so far.

Yoooooooooo you fixed my gears!!! Holy ■■■■ dude your amazing i have the s and it worked perfect