Fix to get Xbox Live to Nat Type - Open ! (PC)

If anyone else, like me, has been stuck on “Nat Type - Moderate” forever for Xbox Live (Windows 10), I finally found a fix. Ever since I got Gears 4 at launch, it annoyed me that it always showed up as “Moderate” in the Xbox App for me. I tried opening ports and messing with command prompt in the past, but it never worked.

Finally, I got it to Open a few minutes ago. Here’s what did it:
image
Source ~ https://www.reddit.com/r/Windows10/comments/9lh28u/how_to_fix_teredo_is_unable_to_qualify_issue_in/

Then:



Source ~ https://answers.microsoft.com/en-us/windows/forum/apps_windows_10-win_xbox/xbox-app-say-nat-type-open-but-server-conectivity/b53270b2-ceb7-4063-a5af-d77b82e23e2a

After trying port forwarding and other instructions on how to uninstall/reinstall Teredo and mess with it’s settings in Command Prompt from Gears 4’s launch until like 2018, I gave up. I only messed with it now because I noticed sometimes when I checked the Network since reinstalling Gears 4 about 2 weeks ago, it would give a message about “Teredo is not able to qualify”, then it’d fix itself after checking Network again.

So I wanted to just get rid of the issue. I got it working, then for the hell of it decided to try one more time to get “Open” Nat Type, expecting it to not work ofcourse. Well, it worked!

Anyways, anyone else stuck on “Strict” or “Moderate” Nat Type, I hope this can help you.

4 Likes

So you pick any number here?

Does it make a difference anywhere else?

I just went with the 60209, UDP and TCP. Then that’s the number you use when you do the “netsh interface Teredo set state client clientport=60209” when you go back into Command Prompt(Admin).

It corresponds to the last port you pick from the list of ports to open:
image
If you chose a random number between 49152 and 65535, that’s the number you use in the command prompt. I chose to just go with 60209, so that’s the number I used in that command line.

There seems to be a bug in the Xbox App and Game Bar when you first open them, that gives the Teredo error on the first Network check always. So you have to check a 2nd time.
image
image
It seems pretty consistent, it always gives an error on NAT Type the first check, usually on Server connectivity too. Then every consecutive check is fine. If you close the Game Bar settings or Xbox App, then reopen them, it’ll do it again, and you have to check atleast twice to get the accurate reading it seems, for me atleast.

I don’t remember that being the case back when I use to play Gears 4, must be a new Win 10 or Xbox App bug.

Yeah,

I’ll give this a go and see how I get on :+1:

Having Moderate actually makes zero difference to Open in my experience (I’ve tried both) - but everyone’s experiences will differ :v:

So much work to open your nat, why not just slap your ip in the dmz host and be done with it?

Yea, it’s just that Open can play with everyone, Moderate and Strict.
Moderate can play with only Moderate and Open.
Strict can only play with Open.

I feel like I tried it in the past and it didn’t work, plus you’re always advised against it for security reasons, so if possible, I rather avoid it. Plus, the little bit more work it takes to get it done the more safe way, you only have to do once and you’re done anyways.

I know it normally works,

But like I said,

Having Moderate with the ports open makes no difference when having Open.

Good of you to share. I’ll add that the NAT can be triggered from a number of things and there’s a few different ways to get it to open, depending what’s causing your situation in the first place.

That is what I do.

I know this is old but this comes up when googling this topic. I followed most of these direction minus one and it fixed it for me. I finally have a Open NAT on my Windows 10 PC. The one thing I didn’t do is the first step. Mainly because I was worried about using teredo.remlab.net because doing a trace route to it reveled its in Germany so latency was bad. So I didn’t do any of the steps in the first picture. Doing the rest though worked perfectly and let me stick with Microsoft’s Teredo server (for me it’s win1910.ipv6.microsoft.com) which has a much lower 30 MS trace route. I did have to restart my PC to get the NAT type to change to Open but it worked.

Thank you for the post.

All you of players are giant nerds.

I’m jealous I can’t understand any of this…

1 Like

I’m thinking about making a video tutorial showing exactly what I did that worked. Esp since this is a issue for everyone with AT&T since they use NAT on all of their gateways and using another router connected to their stuff still dose not get around the NAT issue (if anything just makes it more complicated). If they just used/allowed UPNP on their gateways this wouldn’t be a issue at all. That’s what Teredo is for is getting Xbox Live to work when you’re using a router/gateway that uses NAT.

2 Likes

I made an account to say, this.

THANK YOU SO MUCH.

I spent like 4 hours troubleshooting and talking to customer support on xbox and my ISP and nothing worked until I tried this.