Gears Forums

Co-op campaign is a glitch filled disaster (Potential spoilers)

We have encountered SO many game breaking glitches, we’ve had to restart the campaign SO many times. Just to name a couple…

  1. Player AI getting stuck so we’re unable to progress the campaign at spots, like elevators.

  2. Every time we need to equip a new ability for Jack we need to quit out of our co-op experience because when in co-op the player playing Jack isn’t able to equip new abilities and I’m not allowed to equip them for him. I need to complete these sections in single player and then invite my friends back in after.

  3. Getting through the fire at the end of act 3 after the worm boss appears to be literally impossible on insane with a friend. We tried it over ten times before we just had me do it in solo. Obviously in solo it worked on the first try, but as my friend joined in we were thrown under the map and THEN the game hits the checkpoint, so if we re-launched the game we’d still be under ground. https://clips.twitch.tv/TenuousStormyNoodleUnSane

  4. Jack gets randomly stuck in place and my friend has to re-load the campaign for us to be able to progress.

  5. Game randomly crashing

  6. Enemies either spawning directly next to you or just not spawning at all

  7. Swarm guys getting stuck under the map

Edit: More glitches as I recall/experience.

  1. Both of my party members had the game mute and an electric guitar solo was played during the first part of act 4.

We haven’t gone a full hour without having to disband our party as the result of various glitches. Attempting to finish this campaign has been a test of patience and an exercise in frustration.

1 Like

yeah, had a horrific experience with it with my friends. not going to touch it again for a while. eventually going to play it on insane anyways so ■■■■ it. it seemed like it was good. cant really say though because of how poor of state it is in.

The only reason I haven’t quit is because I know once I’m done I’ll just uninstall the title and hope the next iteration is a little better.

Not to mention that I completed the campaign co-op and didn’t get the finished all acts of the campaign achievement. OH and I got kills with all of the relic weapons, no achievement. OH and I held 3 relic weapons at once, didn’t get the achievement. OH and I’m STILL missing a TON of the collectibles that we picked up.

Talk about quality control dude.

It’s as if this game had to be put out in a year of development and not three with the benefit of being able to re-use a large amount of assets and engine from Gears of War 4

I dunno i enjoyed the cutscenes running at 1 fps and the audio constantly freezing and making loud buzzing sounds

Both non host players had no sound at the start of act 4 for us. Wierdly the hammer of dawn made a guitar noise? :joy:
We had the issue with Jack and the bit where Paddock asks you to equip a new upgrade. When we equipped it he still kept asking so were effectively stuck. We had to switch Jack to the host player to fix this which threw out our progress in completing with one character.
Achievements and collectables would activate for people randomly and I didn’t get the ones for completing the game.
Parts of the campaign we had to keep replaying to kill enemies before they threw undodgable grenades or drop shots (like the drop shot while in the rocket factory lift).

1 Like

I FORGOT ABOUT THAT! We had that glitch as well. Both of my friends said the game muted and they heard an electric guitar solo. Sounds like we experienced a lot of the same problems.