Can't sign up for TCA

Hi all, I’ve been trying to apply for The Coalition Army but because of security concerns, Google blocks the authentication of my accounts from completing the sign up process. Has anyone else run into this? I’ve tried on multiple browsers and I came across this post which describes the error I get when I attempt to authenticate.

Thanks in advance for you assistance.

I tried last year and the same thing happened to me. I wanted to join to get access to in game renders of everything like characters and maps so i could use them for thumbnails but I found out shortly after that TC has all of that on a separate website that anyone can use.

1 Like

I’ve found that website as well. Bummer they seem to have discontinued the program. I was a part of it in 4 and it was a nice way to give something back to the community.

1 Like

Gears Utility has the Content Initiative where you can find a lot of renders, images, audio, and templates available. All you need to do is create an account. Maybe you’ll find what you’re looking for there.

3 Likes

thanks!

1 Like