Can't launch Gears 5 on Xbox Game Pass PC Beta app

I can launch it on my xbox one X no problem. Im not sure what im doing wrong but it wont launch on my pc beta app.

Same here, when i hit play i get a pop up for a dependency app installer, i hit yes and nothing happens

I have game pass ultimate

image
I’ve been getting this message every time I attempt to start on PC with Xbox Game Pass. It’s past 9pm in my area.

Gamepass to Gamepass Ultimate?

1 Like

Ah, didn’t realize I needed Gamepass Ultimate

Gamepass Ultimate gives you the ultimate edition, regular gamepass gives you the regular edition.

2 Likes

yes i have the ultimate edition,. i dont get any errors, it just doesnt launch

1 Like

Can you try opening it from the windows store?

Same issue. Must be a server issue because its basically launch day. Works just fine on the xbox.

1 Like

glad to hear its not just me lol

1 Like

Same problem for me. I have this problem since the tech test. I posted on this forum and on reddit, No official answer. I contacted microsoft support, they told me they would give me news in 24 hours. It’s been 1 month …

1 Like

Has anyone had any luck with this problem yet? I’m currently stuck with a game that I cannot play because of this.

2 Likes

Same issue. Was able to play for 2 hours late last nigt, came back from work with a hunger and i keep pressing the play nothing happens.
Other games work, this sometimes pop a free app in microsoft store which i already have

Ditto.
Originally it would not launch and an error would pop up minutes later
Capture
So I decided to restart my PC, and after that it poured like a kitten. Till I stopped playing.
Now when I click on the shortcut it just brings me to MS Store Gaming Service
I had to stop playing Metro Exodus from MS Store for the exact same reasons.
Gears 5 plays fine on Xbox One, I have tried launching Gears 5 on PC every way possible

I’m the same it wont even start… I click play on the store and it does nothing… I run as administrator from desktop it takes me to Gaming Services app. I’m up to 1903 Winver and latest graphics driver.
tried repairing app from add/remove programs as it wont let you uninstall and reinstall fresh.

very poor launch with very poor support.

2 Likes

I was having this issue. I unistalled the Xbox Game Pass Beta Pc app, then launched the game from the store.

How did you uninstall the app?

I searched the app on the windows search bar, clicked on it with the mouse’s right button, uninstall option is the last I think.

So, looks like my Game Pass some how did not renew from when I first purchased it in August. So I went to the website and purchased the 2 month for $2 (Ultimate Game Pass). Then the game launched right up. I was getting the “you’re too early” message.

Did you figure it out. I just did.